Elementor Warning – controls-stack.php

Today my client told me that his site having an issue. An Elementor Warning: array_merge(): Expected parameter 1 to be an array, null given in /[SERVERPATH]/wp-content/plugins/elementor/includes/base/controls-stack.php on line 1184

I tried some blogs but not found any useful solutions. then I found elementor plugins page comment. one guy having the same issue.

Just follow replace the 1184 number line:

$dynamic_settings = array_merge( $dynamic_settings, $control['dynamic'] );

With

$dynamic_settings = array_merge( wp_parse_id_list( $dynamic_settings ), $control['dynamic'] );

its fixed the issue 🙂

Note: before apply this I recommend back up your files. if the elementor plugin update then the code no longer exist.

Warning: array_merge(): Expected parameter 1 to be an array, null given in /[SERVERPATH]/wp-content/plugins/elementor/includes/base/controls-stack.php on line 1184

on the plugin directory open the controls-stack.php to a code editor and replace this code
$dynamic_settings = array_merge( wp_parse_id_list( $dynamic_settings ), $control[‘dynamic’] );

Leave a Comment

Your email address will not be published. Required fields are marked *

1 Shares
Tweet
Share
Pin
Share1